can not get an ls /directory/subdir | tail -1 to execute

Post any question you may have in regards to GoAnywhere Director and let our talented support staff and other users assist you.
2 posts Page 1 of 1


Posts: 1
Joined: Fri Aug 23, 2013 12:49 pm

Post by paulschiele » Fri May 29, 2015 10:44 am
In Director version 4.6.1 I can't seem to get the right syntax to execute a the below native command in Linux. I have tried several different ways of splitting this up into varialbes in seperate arguments etc. etc. to no avail.

ls /directory/subdir | tail -1

config is as follows:
arg: /directory/subdir | tail -1

Returns this error:
5/29/15 11:23:40 AM INFO Preparing to execute the native command 'ls' with the argument(s) '/directory/subdir/inbound | tail -1'
5/29/15 11:23:40 AM INFO ls: cannot access /directory/subdir/inbound | tail -1: No such file or directory
5/29/15 11:23:41 AM INFO The native command 'ls' finished with a return code of '2'
5/29/15 11:23:41 AM ERROR [9003 - exec] The executable encountered an error with a return code of '2'. To ignore this error, set the attribute 'errorIfExecutableFails' to false.



Support Specialist
Posts: 592
Joined: Tue Jul 17, 2012 2:12 pm
Location: Phoenix, AZ

Post by Support_Rick » Tue Jun 02, 2015 5:15 pm
While GoAnywhere Director provides a way to execute a native command on the local system, “piping” in a command string in Linux is not supported. This pipe “|” function is actually two commands, the result of the first serves as the input for the second. In technical terms, these are two threads. To accomplish the same result, the first command (before the “|”) can be executed with the Execute Native Command task, then the results used in a second Execute Native Command task.
Rick Elliott
Lead Solutions Consultant
(402) 944.4242
(800) 949-4696
2 posts Page 1 of 1