ERROR Licensing initialization failed and java.util.prefs.Fi

Post any question you may have in regards to GoAnywhere Director and let our talented support staff and other users assist you.
1 post Page 1 of 1

Michael Hoppe

Posts: 3
Joined: Thu Dec 18, 2014 8:14 am

Post by Michael Hoppe » Thu Jun 23, 2016 12:54 pm

as part of an migration to new Hardware we are currently having trouble installing the currently used GA Services and GA Director version.

We tried to install the following versions:

GA Director 4.6.1: ...
GA Services 3.5.1: ...

to a new:

Oracle Linux Server release 6.6
• Red Hat Enterprise Linux Server release 6.6 (Santiago)

All together we were facing two new issues. At first we were facing a repeating warning throughout the installation process of both scripts.
Code: Select all
Jun 22, 2016 8:37:25 AM java.util.prefs.FileSystemPreferences checkLockFile0ErrorCode
WARNING: Could not lock System prefs.Unix error code 0.
Jun 22, 2016 8:37:25 AM java.util.prefs.FileSystemPreferences syncWorld
WARNING: Couldn't flush system prefs: java.util.prefs.BackingStoreException: Couldn't get file lock.
And after the installation was completed we had trouble with the intial license file creation. When starting both application for the first time we received the following issue (which is actually als mentioned in the install documents):
Code: Select all
6/22/16 8:54:27 AM ERROR Licensing initialization failed. 
com.linoma.license.LicenseException: Licensing initialization failed. 
        at com.linoma.startup.TomcatStarter.start(Unknown Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.linoma.bootstrap.GoAnywhereBootstrap.main(Unknown Source)
Caused by: com.linoma.dpa.dao.DAOException: Couldn't get file lock.
        at com.linoma.dpa.license.DefaultSerialNumberDAO.getSerialNumber(Unknown Source)
        ... 6 more
Caused by: java.util.prefs.BackingStoreException: Couldn't get file lock.
        at java.util.prefs.FileSystemPreferences.sync(Unknown Source)
        at java.util.prefs.FileSystemPreferences.flush(Unknown Source)
        at com.linoma.dpa.license.DefaultSerialNumberDAO.createSerialNumber(Unknown Source)
        ... 7 more
6/22/16 8:54:27 AM INFO  Database was shutdown. 
6/22/16 8:54:27 AM INFO  GoAnywhere Services was shut down. 
gaservices.log (END)
We are aware that the documentation is mentioning a quite easy solution for this, which is to start the initial licensing process by stating both tools up as root. Unfortunately this did not change anything:
Code: Select all
[email protected] goanywhere_services]# ./ start license
Using CATALINA_BASE:   /apps/mft/nonprd/cs/MFT/goanywhere_services/tomcat
Using CATALINA_HOME:   /apps/mft/nonprd/cs/MFT/goanywhere_services/tomcat
Using CATALINA_TMPDIR: /apps/mft/nonprd/cs/MFT/goanywhere_services/tomcat/temp
Using JRE_HOME:        ././tomcat/bin/../../jre
Using CLASSPATH:       /apps/mft/nonprd/cs/MFT/goanywhere_services/tomcat/bin/goanywhere_bootstrap.jar
Using GAS_HOME:	       /apps/mft/nonprd/cs/MFT/goanywhere_services
So now my question. Has anybody encountered the same Warning while installing the tools and has also solved the mentioned licensing issues??

Regarding the warning, i just would like to understand if this is a real issue or can be ignored by us.

I would appreciate your help with this two problems as We are quite out of ideas :).

Thanks in advance,

1 post Page 1 of 1