MAC & Connectivity

Post any question you may have in regards to GoAnywhere Services and let our talented support staff and other users assist you.
3 posts Page 1 of 1


Posts: 13
Joined: Tue Jul 23, 2013 9:19 am
Location: London, ON, CA

Post by cfowler » Wed Feb 12, 2014 3:03 pm
Hey all;

I've run into an issue where a client cannot access our site via MAC OS X 10.9.1, which I'm totally unfamiliar with. It appears to be a Java related issue but since I'm not familiar with OS X I thought I'd post it here.

OS - OS X 10.9.1, Safari 7.0.1 with Java 7_51.

User can connect and see all folders. User traverses folders and downloads a file. After the download the user sometimes gets an error when going back up to the root folder "working directory "name of folder here" does not exist". This is inconsistent.

Also, when the user, via the Enhanced interface, tries to right click and download a file, they receive an error message stating "operation not permitted" which is on the client side.

I've tried uninstalling Java and resetting the security. I've tried adding the HTTPS site to the java security but I'm at a loss as to where else to look. I also scanned through the GA documentation but couldn't find anything regarding MAC & Java at the client level.

Greatly appreciate any suggestions!




Support Specialist
Posts: 62
Joined: Thu Jul 19, 2012 9:15 am
Location: Ashland, NE

Post by Support_Jon » Thu Mar 13, 2014 9:58 am
For issue 1, We believe the user is navigating back up the directory tree using the browser back button. This is a known behavior and can be recreated in any browser and any OS by downloading a file and then click the browser back button. It will present the error you mentioned. Back buttons must not be used. The user must navigate up the directory by using the Up Directory icon.

For issue 2, We couldn’t reproduce that issue in house. Please ensure that the Web User profile has full download permissions. Also confirm that the end user is downloading the file to a directory where they have full access. It is possible they are navigating to a directory (Network Resource) in the local pane that they do not have write access to. You may want to have them navigate to their desktop and attempt to transfer files there.

In addition, please have them make sure their Safari preferences is allowing Safe downloading : Safari > Preferences > General > Open "safe" files after downloading.

Thanks - Jon


Posts: 13
Joined: Tue Jul 23, 2013 9:19 am
Location: London, ON, CA

Post by cfowler » Tue Mar 18, 2014 1:34 pm
Thank you for the response. I ended up placing a support call while I was waiting for my post to be approved. The support technician suggested the following, which resolved my issue.

1. open safari;
2. click safari / preferences;
3. ensure there is a check in the box for "Internet plug-ins"';
4. click on Manage Website Settings;
5. select Java in the left pane and in the right pane select the secure site, change "always allow" to "run in unsafe mode".
6. click Trust when asked.

Allowing the site to run in unsafe mode was the only resolution that solved the navigation issue.


3 posts Page 1 of 1