cannot FTP put a file...

Post any question you may have in regards to GoAnywhere Director and let our talented support staff and other users assist you.
2 posts Page 1 of 1


Verified User
Posts: 2
Joined: Fri Oct 09, 2009 12:39 pm

Post by jenni » Tue Oct 20, 2009 3:39 pm
I cannot seem to put a file to one of my servers. The test worked just fine when I set up the resource, I browse to the folder I want to upload the file to just fine when I create the Project but when I run it it fails with the error below. If I just sit at the command line for the server GoAnywhere runs on, FTP to the destination server logging on with the same ID/password I entered in GoAnywhere, I am able to put the file without any trouble. I looked through these forums for a possible solution and saw the post about having a $ in the password but this ID does not have a $ in the password... TIA!!

10/20/09 2:14:14 PM ERROR [8098 - putCactusFile] 550 / Access is denied.

com.linoma.dpa.runtime.JobFailedException: [8098 - putCactusFile] 550 / Access is denied.

at Source)
at com.linoma.dpa.runtime.Runtime.executeProject(Unknown Source)
at com.linoma.dpa.j2ee.forms.ProjectListForm.runProject(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.apache.el.parser.AstValue.invoke(
at org.apache.el.MethodExpressionImpl.invoke(
at org.apache.myfaces.el.convert.MethodExpressionToMethodBinding.invoke(
at org.apache.myfaces.application.ActionListenerImpl.processAction(
at javax.faces.component.UICommand.broadcast(
at javax.faces.component.UIData.broadcast(
at org.ajax4jsf.component.AjaxViewRoot.processEvents(
at org.ajax4jsf.component.AjaxViewRoot.broadcastEvents(
at org.ajax4jsf.component.AjaxViewRoot.processPhase(
at org.ajax4jsf.component.AjaxViewRoot.processApplication(
at org.apache.myfaces.lifecycle.InvokeApplicationExecutor.execute(
at org.apache.myfaces.lifecycle.LifecycleImpl.executePhase(
at org.apache.myfaces.lifecycle.LifecycleImpl.execute(
at javax.faces.webapp.FacesServlet.service(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.myfaces.webapp.filter.ExtensionsFilter.doFilter(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.ajax4jsf.webapp.BaseXMLFilter.doXmlFilter(
at org.ajax4jsf.webapp.BaseFilter.handleRequest(
at org.ajax4jsf.webapp.BaseFilter.processUploadsAndHandleRequest(
at org.ajax4jsf.webapp.BaseFilter.doFilter(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at Source)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.catalina.core.StandardWrapperValve.invoke(
at org.apache.catalina.core.StandardContextValve.invoke(
at org.apache.catalina.core.StandardHostValve.invoke(
at org.apache.catalina.valves.ErrorReportValve.invoke(
at org.apache.catalina.core.StandardEngineValve.invoke(
at org.apache.catalina.connector.CoyoteAdapter.service(
at org.apache.coyote.http11.Http11Processor.process(
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(
Caused by: com.linoma.dpa.ExecutionException: [8098 - putCactusFile] 550 / Access is denied.

at com.linoma.dpa.ProjectUtilities.getExecutionException(Unknown Source)
at com.linoma.dpa.tasks.ftp.PutAction.execute(Unknown Source)
at com.linoma.dpa.tasks.ftp.AbstractFTPTask.execute(Unknown Source)
at com.linoma.dpa.Module.execute(Unknown Source)
at com.linoma.dpa.Project.execute(Unknown Source)
at com.linoma.dpa.runtime.Job.executeProject(Unknown Source)
... 45 more
Caused by: com.linoma.dpa.tasks.ftp.FTPInterfaceException: 550 / Access is denied.
at com.linoma.dpa.tasks.ftp.FTPImpl.upload(Unknown Source)
at com.linoma.dpa.tasks.ftp.PutAction.processFile(Unknown Source)
at com.linoma.dpa.tasks.ftp.PutAction.uploadFiles(Unknown Source)
... 50 more
Caused by: com.jscape.inet.ftp.FtpException: 550 / Access is denied.
at com.jscape.inet.ftp.FtpBaseImplementation.checkResponse(
at com.jscape.inet.ftp.FtpBaseImplementation.openDataConnection(
at com.jscape.inet.ftp.FtpBaseImplementation.upload(
at com.jscape.inet.ftp.Ftp.upload(
at com.jscape.inet.ftp.Ftp.upload(
... 53 more
10/20/09 2:14:14 PM INFO End Date and Time: 10/20/09 2:14:14 PM


User avatar
Support Specialist
Posts: 91
Joined: Thu Mar 05, 2009 3:49 pm
Location: Ashland, NE USA

Post by Support_Julie » Wed Oct 21, 2009 9:10 am
This error appears to be caused by a lack of permission on the file or the file could be locked.
Please verify that you have authority to write to the root directory.

Also, instead of placing a '/' in front of the file name, put a PERIOD. This will put the file in the current directory for your user id.
Instead of
Enter for the destination file name
Julie Rosenbaum
Sr Support Analyst
e. [email protected]
p. 1.800.949.4696
2 posts Page 1 of 1